关于最新版cocoapods安装react-native环境出异常问题。

电脑重装系统后重新安装的环境,很多工具都默认安装了最新版,使用cocoapods安装依赖后在xcode运行时React-99异常,,一开始很奇怪这个错误在之前根本没有过,查看xcode pod target中发现多了一个React-99*的依赖,尝试删除后发现可以运行了,但是这种解决方案很麻烦, 每次如果出现重新Pod install后都要去删除这个错误的安装依赖,最终查看了cocoapods版本后

pod --version
//1.8.1

尝试降低pod版本

//先卸载现有安装版本
sudo gem uninstall cocoapods
//再安装之前没错误的版本
sudo gem install cocoapods -v 1.6.1

重新cd ios && pod install 后xcode运行无错误


发表新评论