menu
refresh
shufu
这是一个前端开发记录Debug过程和杂谈的博客
关于最新版cocoapods安装react-native环境出异常问题。
access_time
brush 158个字
whatshot 66 ℃

电脑重装系统后重新安装的环境,很多工具都默认安装了最新版,使用cocoapods安装依赖后在xcode运行时React-99异常,,一开始很奇怪这个错误在之前根本没有过,查看xcode pod target中发现多了一个React-99*的依赖,尝试删除后发现可以运行了,但是这种解决方案很麻烦, 每次如果出现重新Pod install后都要去删除这个错误的安装依赖,最终查看了cocoapods版本后

pod --version
//1.8.1

尝试降低pod版本

//先卸载现有安装版本
sudo gem uninstall cocoapods
//再安装之前没错误的版本
sudo gem install cocoapods -v 1.6.1

重新cd ios && pod install 后xcode运行无错误


#如无特别声明,该文章均为 shufu 原创,转载请遵循 署名-非商业性使用 4.0 国际(CC BY-NC 4.0) 协议,即转载请注明文章来源。
#最后编辑时间为: 2019 年 11 月 23 日


account_circle
email
explore


DreamCat

主题名称:DreamCat | 版本:X1.6-20201226

主题开发:HanFengA7 | TeddyNight | Dev-Leo | CornWorld

鸣谢:学神之女

鸣谢:学神之女